View Full Version : Glitches

Jan 3, 2009, 12:59 PM
I thought we might as well have a thread where we pool the glitches we encounter together.

I'll start it off with these:

1. Playing through eternal tower, somewhere around the 51st floor my teammates stopped responding to orders. They didn't cast any techs and so kept dying constantly. I thought it might be a "realistic" way of them running out of fluids, but they also completely stopped responding to orders concerning PB blasts. I thought a quick trip to the city might sort of reset their AI, so I let myself die. Lo, behold, as soon as I returned to the tower they started responding to all commands again.

2. While firing off a PB, i fumbled with the buttons by accident. This had the result that the PB went off, but I could still move around and shoot while I watched my PB race around the room and give me the boost after it completed its round. Not bad! I haven't been able to recreate it, though.

3. In Eternal Tower, the boss on the 70th floor didn't appear as normal when I went into the room. I was free to run around the room, desperate in the thought that I might have to start all over. Luckily, moving about in the entrance area finally triggered the boss's arrival.

Got any more?

Jan 3, 2009, 03:37 PM
The third one also happened to me >_> Luckily it happened at the tenth floor but it was still frustrating and running around the room didn't help ><

Jan 3, 2009, 04:16 PM
I had to sort of run back and forth around the area where you first enter before it happened.

Jan 3, 2009, 05:43 PM
The tower bosses never glitched on me. They do wait for you to come near, usually.

Most of the glitches I've found were so minor that you'd almost never notice if you weren't looking for them. Aside from that, most are related to terrible pathfinding algorithms. Those guys at the end keep getting stuck on the walls and Ogi is really bad with walls.

Clipping is kind of terrible over all. Movement deflection is pretty bad (about as bad as PSO, maybe a bit worse) and it's really nasty when a monster is just at the edge of a boundary and you have roughly a 30 degree angle to hit them from despite the boundary being a straight line (so you should get roughly 180 degrees.)

Jan 3, 2009, 06:33 PM
They do wait for you to come near, usually.
Just to make it abundantly clear. That's not what's going on here.

Jan 3, 2009, 07:02 PM
I ran all over the map, I guess the game just didn't load the boss since I don't think there was a slight pause like there usually is. Not really a glitch, but I find it annoying when you at the edge of an area and try to do a photon art, but get stuck in one place. Nothing major, just a bit annoying x_X

Jan 3, 2009, 08:05 PM
Just to make it abundantly clear. That's not what's going on here.

I think it might just be exactly what's going on. At least 50% of the times I've fought one, the boss doesn't show itself (not even on radar) until I got close to it. It really seems intentional, but if it glitched up while doing that it might seem like the whole thing is glitched. OTOH, it might just be a problem with loading the model data, since the engine uses model data for most actions, it wouldn't be able to attack or take hits until it's fully instantiated.

That reminds me, there's a glitch with at least one PA, and probably others. I have some 6* mechguns that have a PA where you go into bullet time and dive forward then spin around firing shots in slow-mo. If you get frozen, the shots still go off, out of the gun barrels (see above about actions and model data) then when the effect wears off, you'll still spin around with muzzle flashes and everything, but no shots. (If you get slowed, everything goes out of sync.) Also, while spinning, if you're locked on to a moving target you'll move around in tandem... it's a really weird effect.

Jan 4, 2009, 04:10 AM
Gunslash Quick Fire?

Not sure if this could really be considered a glitch but normally it takes a while to get my shots off while using the gunslash. If you tap left or right immediately after firing, you'll be to fire again more quickly. Its effective when you're close enough to a monster for all three shots to connect. Its also seems useful for applying SEs even with lv1 elements.

Jan 4, 2009, 11:02 AM
I think it might just be exactly what's going on. At least 50% of the times I've fought one, the boss doesn't show itself (not even on radar) until I got close to it. It really seems intentional, effect.
No. You are absolutely right that it is intentional that the boss never shows itself before you get close to it, but that's still not what's going on. Even if the boss was "hiding" in the exact spot of the entrance, then it should appear once you are there. It did not. I was free to roam all areas of the room, which I did, with no sight of the boss. He usually comes up as you approach the center. What I had to do was go back to the very edge of the entrance area and walk about there a bit. Seemed like a glitch where the engine hadn't registered my entrance.

Anyway, why are we debating this? It's a glitch no matter which way we look at it!

Jan 4, 2009, 11:39 AM
That's what I mean though -- it's clear that the boss is moving around even before it appears. I don't mean that there's no glitch here, I'm saying that the designed behavior and the glitch that probably does exist are possibly inseparable, short of hooking up a debugger and taking a look or successfully triggering the boss. If the boss moves around and won't appear until you get close, how can you tell when it's glitched vs. simply not running into the boss through pure bad luck?

Jan 4, 2009, 12:15 PM
Well, I usually (the 12 other times I've done the boss) approach the middle of the room straight ahead and the boss starts to load well before I reach the center. It hasn't been my experience the the boss invisibly darts around the room before loading.

Jan 4, 2009, 01:45 PM
If you wait for a moment or two before moving into the room, I bet you'll start to see what I'm seeing. Maybe that's the glitch, but it seemed like a really neat effect to me.

Jan 4, 2009, 06:37 PM
you know how there is a entrance to a new level but you must have all your party members at the entrance before proceeding? i did a roll and i passed by the blue gate thing. lol