Results 1 to 2 of 2
  1. #1

    Default 0x800705B4 after Microsoft Store attempts to Acquire License

    I hit the blue Install button in Microsoft Store. It says Acquiring License... takes a minute then gives the error 0x800705B4. I notice Gaming Services also attempts to Acquire License as well. It also gets the same error. Not sure what that implies. I also tried installing other apps and updates and none had any problems. Only PSO2 and Gaming Services.

    Oh! I also noted they both get the error at the same time if that helps too.
    And whats up with Microsoft Store taking so long to open? It shows the window quickly but loads and loads... Everything else is lightning fast.
    I just got this laptop the other day...
    Last edited by aleckeene; Jun 5, 2020 at 10:29 PM.

  2. #2


    I actually figured it out. Just had to verify my "identity" in microsoft account settings. I did so client-side, not through the website; I'm not even sure there is a way to do it through the website. Anyway, I'll leave this here in case another dork gets this and searches for that error code. Happy hunting.

Similar Threads

  1. Attempting to come back after long absence
    By Calsetes in forum PSO2 General
    Replies: 3
    Last Post: Apr 19, 2017, 09:48 PM
  2. PSO2 GN Field Microsoft .NET Framework problem after launching the game
    By SoultyRagevin in forum Tech Support
    Replies: 0
    Last Post: Feb 17, 2017, 11:44 AM
  3. Replies: 4
    Last Post: Mar 20, 2007, 05:12 AM
  4. Store name not appearin after search?
    By drmcst45 in forum PSU General
    Replies: 8
    Last Post: Dec 7, 2006, 03:23 PM
  5. Hunter's License
    By xeku in forum Tech Support
    Replies: 3
    Last Post: Feb 16, 2001, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts