PSO-World.com Phantasy Star NewsPSOW ForumsPSU Items DatabaseGuides Database
Register Site Links FAQ/Rules Forums Groups Search Today's Posts Mark Forums Read
Go Back   PSO-World.com Forums > Phantasy Star Online 2 > PSO2 General
Reload this Page Reasons/solutions for PSO2 crashing with shading enabled.

Reply
 
Thread Tools Display Modes
Reasons/solutions for PSO2 crashing with shading enabled.
Old
  (#1)
Coatl is Offline
Mr. Congenial
 
Coatl's Avatar
 
Posts: 2,271
Join Date: Mar 2012
   
Default Reasons/solutions for PSO2 crashing with shading enabled. - 06-15-2012, 06:34 AM

Hey there.

I've made this thread is to draw out the reasons (and if possible solutions) for PSO2 when shadowing/shading is enabled. I'll be buying a new PC pretty soon, and it that solves it then great. But I'd like to know exactly what is the problem though.

Last edited by Coatl; 06-15-2012 at 02:59 PM..
  
Reply With Quote
Old
  (#2)
TechnoV is Offline
Rappy Hunter
 
Posts: 14
Join Date: Apr 2012
   
Default 06-15-2012, 01:56 PM

Mine was crashing whenever I would try to create a character. Is this what caused it? If so, how can I turn off shadowing so that I can play tomorrow?
  
Reply With Quote
Old
  (#3)
Aeris is Offline
Nya Cat Lover =P
 
Aeris's Avatar
 
Posts: 1,093
Join Date: Jun 2008
Location: Arkansas
PSŲ FC: 5242 2895 2739
   
Default 06-15-2012, 02:41 PM

Usually having the slider higher to the right at 3 and higher have the shaders on, 2 and 1 has it off, turning it higher and your gpu can't handle it might make your game crash at certain points, try turning it lower and see if that fixes your issue, really donno where the shadowing option is though.
  
Reply With Quote
Old
  (#4)
buri-chan is Offline
Pretentious Idiot
 
buri-chan's Avatar
 
Posts: 368
Join Date: Mar 2012
Location: Minnesota
   
Default 06-15-2012, 02:47 PM

Open the launcher.
Choose the second button down to open the config screen.
Open the fourth tab to the right.
Here are the graphics options that are changed by the slider. On the left you've got the detail going high to low from top to bottom, and the box on the right changes whether the shadowing is enabled. Top is on, bottom is off. Generally speaking, the settings go:

1 - Low Textures, Shadowing Off
3- Medium Textures, Shadowing On
5 - High Textures, Shadowing On

To save settings, click the bottom-right button, then click the left button in the dialog box that comes up. What card are you running it on? If it's old enough to be replaced, it really might be the problem, sad to say.
  
Reply With Quote
Old
  (#5)
Coatl is Offline
Mr. Congenial
 
Coatl's Avatar
 
Posts: 2,271
Join Date: Mar 2012
   
Default 06-15-2012, 02:47 PM

Quote:
Originally Posted by Aeris View Post
Usually having the slider higher to the right at 3 and higher have the shaders on, 2 and 1 has it off, turning it higher and your gpu can't handle it might make your game crash at certain points, try turning it lower and see if that fixes your issue, really donno where the shadowing option is though.
I am not necessarily looking to fix the issue, I am more looking for the reason for why the issue exists. Turning the shader off does fix the problem though.

It being because of GPU is a viable reason though.

Quote:
Originally Posted by buri-chan View Post
What card are you running it on? If it's old enough to be replaced, it really might be the problem, sad to say.
My graphics card is ATI Mobility Radeon HD 4200.
Not going to manage?

Last edited by Coatl; 06-15-2012 at 03:02 PM..
  
Reply With Quote
Old
  (#6)
Crevox is Offline
Rag Rappy
 
Crevox's Avatar
 
Posts: 201
Join Date: Dec 2007
   
Default 06-15-2012, 04:00 PM

Quote:
Originally Posted by Coatl View Post
I am not necessarily looking to fix the issue, I am more looking for the reason for why the issue exists. Turning the shader off does fix the problem though.

It being because of GPU is a viable reason though.



My graphics card is ATI Mobility Radeon HD 4200.
Not going to manage?
That card is an onboard card, so I would be surprised if it runs this game at all...

Technically it's not even a GPU, it's not a dedicated processing unit.
  
Reply With Quote
Old
  (#7)
Scotty T is Offline
ヨーヨー犬
 
Posts: 150
Join Date: Jan 2012
Location: X to the Z
   
Default 06-15-2012, 04:02 PM

Get 550 Ti, BOOM. Sorted.
  
Reply With Quote
Old
  (#8)
Neoistheone is Offline
Neo
 
Neoistheone's Avatar
 
Posts: 406
Join Date: May 2002
Location: West Virginia
 Send a message via ICQ to Neoistheone Send a message via AIM to Neoistheone Send a message via MSN to Neoistheone Send a message via Yahoo to Neoistheone Send a message via Skype™ to Neoistheone 
Default 06-15-2012, 04:02 PM

You can try updating the drivers and then updating your DirectX.


EVGA x58 Classified 759 Motherboard, Intel 990X CPU @ 4.2 GHz
Corsair 1200 watt Power Supply, 12 GB DDR3 Corsair
3x GTX 480's in SLi, Corsair 800D Case
Please Read, Connection Issue Template.
  
Reply With Quote
Old
  (#9)
vanishingstapler is Offline
Hunter Rappy
 
Posts: 6
Join Date: Apr 2012
   
Default 06-15-2012, 04:07 PM

Quote:
Originally Posted by Coatl View Post
I am not necessarily looking to fix the issue, I am more looking for the reason for why the issue exists. Turning the shader off does fix the problem though.

It being because of GPU is a viable reason though.

My graphics card is ATI Mobility Radeon HD 4200.
Not going to manage?
My laptop has an ATI Mobility Radeon HD 4250 and the game crashes with shaders on as well. I think the frame rate would probably be too slow if I could use them, though.
  
Reply With Quote
Old
  (#10)
TechnoV is Offline
Rappy Hunter
 
Posts: 14
Join Date: Apr 2012
   
Default 06-15-2012, 05:29 PM

The slider fixed it! I couldn't figure out what was wrong this morning, but at least I'll be able to participate in part 2 of the POBT. Desert/Bouquet rifle, here I come.
  
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All PSO and PSU images and official illustrations are (C) SONICTEAM / SEGA, 2000-2011. All logos and trademarks in this site are property of their respective owners. The comments are property of their posters. All the rest © 2000-2012 PSO-World.com.