PSO-World.com Phantasy Star NewsPSOW ForumsPSU Items DatabaseGuides Database
Register Site Links FAQ/Rules Forums Groups Search Today's Posts Mark Forums Read
Go Back   PSO-World.com Forums > Player Support Area > Tech Support
Reload this Page JP PSO2 Character+monster models do not show?

Reply
 
Thread Tools Display Modes
Character+monster models do not show?
Old
  (#1)
hendo27 is Offline
Rappy Hunter
 
Posts: 1
Join Date: Apr 2013
   
Default Character+monster models do not show? - 04-07-2013, 03:22 PM

I have this problem where the character or monster models are not showing, I can see stuff like hats of people or horns of monsters, but everything else is invisible.

System specs:
AMD A4 3305M APU 1.90GHZ
4GB DDR3 RAM
AMD RADEON HD6470M (high performance gpu)
AMD RADEON HD6480G (power saving gpu)

I've tried using both gpus and I get the same results :/ has anyone had the same problem as this? All my drivers are up to date, I have tried running the folder checks and stuff, re-downloaded the game. It even happens in the benchmark testing. (where I get like 40+fps so my pc should have no problem running the game)

http://i.imgur.com/PkFMunW.jpg

Last edited by hendo27; 04-07-2013 at 03:28 PM..
  
Reply With Quote
Old
  (#2)
AIDA is Online
Director of the Universe
 
AIDA's Avatar
 
Posts: 3,933
Join Date: Jul 2008
  Send a message via Skype™ to AIDA 
Default 04-07-2013, 05:46 PM

General Advice
Here are some things to try if you haven't already:

1) Update DirectX
Every new version of DirectX contains bug fixes so if you are having trouble, this should be your first step. You can get the latest version from Microsoft's Website directly here

2) Run a File Check
The 3rd option on the launcher 「ファイルチェック」 is used to check that all game files are present on your system. If anything is missing, it should download it automatically. It will also replace any files that may have been modified, intentionally or otherwise.

3) Update your drivers
Especially your video card driver! Check with the manufacturer of your video card. Many manufacturers have programs which can automatically identify and install the most recent driver for your card.

For AMD/ATI: http://support.amd.com/us/gpudownloa...to_detect.aspx
For Nvidia: http://www.nvidia.com/Download/Scan.aspx?lang=en-us

4) Free up space on your hard drive

Try freeing up at least 2GB of space on the hard drive where you have PSO2 installed - This will typically fix graphical errors and loading issues, but can also fix other problems as well.

5) Disable your firewall to see if it fixes the problem
Incorrectly configured firewalls/antivirus programs can cause issues with PSO2. If you're having an issue, and have already tried the steps above, please disable your firewall and antivirus, and try running the game again. If it works, you'll need to add an exception in your firewall/antivirus program for PSO2.

6) Reduce your graphics settings
Some graphics cards and PSO2 don't play nice together. Try going into the options menu「環境設定」(2nd option in the launcher) and lowering the slider to 1. If this fixes your problem, go back into the settings, raise it to the next number, then try again, until it starts having the issue again. Once it starts having the issue again, set it back to the previous working number.

Switching to Simple Shaders

Some people have reported success using this, even if the above instructions did not work.

In the options, click 描画 and check the option in the screenshot below
Spoiler!

Then click the bottom left option to save and the bottom right option to return to the launcher.

7) Avoid permission issues

With the introduction of Windows 7/8, Windows has gotten really upset about permissions and ownership and such. This has caused a number of problems with games, and other programs.

Copy the entire folder where you have PSO2 installed (Typically "C:\Program Files\SEGA\PHANTASY STAR ONLINE 2\" or "C:\Program Files (x86)\SEGA\PHANTASY STAR ONLINE 2\") and paste it on the root of your drive (So it's now C:\PHANTASY STAR ONLINE 2\"). Try running the launcher/game from there instead, and see if it works.

If it does, simply make a shortcut to the pso2launcher.exe in the new folder and replace the default shortcut it made in the start menu during the installation.



Quote:
Originally Posted by gigawuts View Post
People here are accounting for Sakai's Law, which states that any design decision that can go wrong will go wrong.
  
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All PSO and PSU images and official illustrations are (C) SONICTEAM / SEGA, 2000-2011. All logos and trademarks in this site are property of their respective owners. The comments are property of their posters. All the rest 2000-2012 PSO-World.com.