Results 1 to 5 of 5
  1. #1

    Default Persistent & Predictable Error 630s w/LF & Story patches installed via Tweaker

    Apologies if this is posted in the wrong place.

    I've been having issues with curiously-predictable Error 630 problems, and I don't think they're related to my connection. I'll explain.

    Prior to Sega's PSO2 patch on Aug. 26th, all patches (English, Large Files, Story, and Item translation) worked fine.

    After the patch, however, I uninstalled the existing patches, and waited for them to be listed as "Compatible" in the Tweaker before reinstalling them.

    This is the important part to remember: with no patches and a vanilla JP PSO2 installation, I had no issues whatsoever.

    Once all three major patches were green-lit as compatible, I re-installed them via the tweaker. Immediately, I noticed that every time I attempted to enter the game after selecting a character, I'd lag horribly or outright 630 when loading into the Gate area.

    Suspicious that the patches were the issue (since they were the only thing that had changed) I uninstalled them all. The 630 issue continued.

    So I reinstalled PSO2 entirely. This time I installed only the base English patch. With a clean install and just the English patch, everything was fine.

    Wondering if the matter was a fluke, I reinstalled the Large Files and English Patches once again. I began to recieve the 630 issue once more when entering the game after choosing a character.

    I then uninstalled all the translation patches, and used the Check for Old/Missing Files option in the Tweaker. I stopped recieving the 630 issue.

    So, to recap, and for those who TL;DRed at the sight of this post...

    Clean Install: No issues
    Clean Install w/English Patch Only: No Issues
    Clean Install w/English Patch and any combination of Large Files or Story Patch: Error 630
    Dirty Install after uninstalling all Translation Patches: Error 630

    Hopefully this is thorough enough of an explanation. Anyone know just what's going on here?
    Last edited by Nerva; Sep 1, 2015 at 07:03 AM. Reason: More info

  2. #2


    Have you run any network tests? Ping, traceroute, packet loss count, ect?

  3. #3


    Ping and Traceroute were the first things I thought of.

    Ping test to Ship2's IP at returned consistent time-outs, probably due to the dead hosts mentioned below. Either that or the host simply refuses ping requests that aren't from a recognized client program - not atypical for a game server that risks being DDoSed by flood attacks.

    Traceroute via WinMTR to the same IP shows four dead hosts at hops 10, 12, 13, and 14, but these are all successfully routed-around and aren't causing any packet loss at the destination IP.

    As I mentioned, I do not think this is an issue with my connection. If these results were interfering, then I would be experiencing the problem no matter what my patch state, and I'm not.

  4. #4


    Try another DNS, i'm using openNIC dns JP server. God knows what happened to your data at those 4 nodes, last month my tracerout result pointed out a node that reach 500ms ping while at destination it was 80ms. And there're many factors that counted, I'm using cascade VPN ( my pc -> local server->JPserver) and rarely have 630 while connecting directly to VPN JPserver will result in 630 if there is no network activity from game client. I use engpatch with story patch btw, so you can be assured that patches aren't the cause

  5. #5


    I tried that, too.

    I have used both OpenDNS and Google's public DNS, with no change. Both route through the same four dead servers. I've also tried using the PSO2Proxy as well, with no change.

    Let me show you an excerpt from my WinMTR traceroute:

    |                                      WinMTR statistics                                   |
    |                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
    |                               ...       -    0 |  516 |  516 |    0 |    0 |    2 |    0 |
    |                               ...       -    0 |  516 |  516 |   21 |   23 |   31 |   22 |
    |                               ...       -    1 |  512 |  511 |   21 |   22 |   29 |   23 |
    |                               ...       -    1 |  512 |  511 |   21 |   22 |   43 |   22 |
    |                               ...       -    0 |  515 |  515 |   29 |   30 |   38 |   32 |
    |  10gigabitethernet4-1.core1.chi1.he.NET -    0 |  515 |  515 |   29 |   35 |   78 |   34 |
    |     -    1 |  512 |  511 |   81 |   84 |   98 |   86 |
    |      -    0 |  514 |  514 |   82 |   86 |  108 |   93 |
    |softbank-bb-corp.gigabitethernet2-14.... -    1 |  512 |  511 |  210 |  211 |  226 |  210 |
    |                   No response from host -  100 |   93 |    0 |    0 |    0 |    0 |    0 |
    |                 -    1 |  499 |  495 |  171 |  173 |  190 |  175 |
    |                   No response from host -  100 |   93 |    0 |    0 |    0 |    0 |    0 |
    |                   No response from host -  100 |   93 |    0 |    0 |    0 |    0 |    0 |
    |                   No response from host -  100 |   93 |    0 |    0 |    0 |    0 |    0 |
    |                -    1 |  507 |  505 |  170 |  177 |  356 |  173 |
    |        -    1 |  512 |  511 |  170 |  175 |  199 |  173 |
    |                 -    1 |  501 |  498 |  186 |  188 |  278 |  189 |
    |                 -    1 |  511 |  510 |  182 |  183 |  213 |  183 |
       WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
    I edited out some of the source IPs to protect my anonymity. As you can see, the destination IP recieved over 98% of sent packets with less than 2% packet loss and an average ping of 183, despite the fact that there's four dead hosts in the way.

    Your explanation doesn't account for why I'm being 630'ed with any patch installed aside from the base english patch.

    UPDATE: I'm trying to find out if it's a specific patch or any of the three (large files, story, item translation) that's causing the issue.

    After getting myself back to a 'clean' state (JP + base EN patch), and verifying that the 630 errors aren't occurring, I installed the Story Patch, since HentaiLolicon indicated that he or she had no problems with it.

    I then started the game and the 630 issues began. Just as before, any time I attempted to load into the gate area, I'd wind up 630'ed.

    I can verify that the Story Patch is causing problems for me.

    I guess the next step is to see if the Large Files patch is doing the same... after I get back to a clean state.

    Return of the UPDATE: Something interesting happened when I closed the game, and then attempted to start the tweaker again to return to a clean state.

    It said the tweaker was already running.

    Isn't the tweaker supposed to close once the game is running, unless the item translation patch is active? Could this be stupidly-simple problem of the tweaker not closing out its process properly, and interfering with the game's loading due to being resident in the background?

    I'm going to do some more tests on this hypothesis. Once I'm back to a clean state, I'm going to install the Large Files patch, then once it's installed I'm not going to start the game immediately. I'm going to completely shut down and restart my computer, to make sure the Tweaker process is very definitely dead, before starting it up and running the game.

    If this hypothesis is correct, I'm going to feel like the biggest idiot.

    Revenge of the UPDATE: Oh my giddy aunt. I think my hypothesis was just proven correct.

    Here's what I did.

    First, I returned to a clean state. Uninstalled all patches, used the old method of updating to clean up any leftovers. Closed the tweaker and restarted my computer, then opened the tweaker and installed the English patch.

    Logged into verify, and no 630 error, as expected.

    So then I installed the Large Files patch. Logged in and 630ed at the gate, again as expected.

    Rather than closing the game when the 630 happened, I decided to let it go back to the title screen. I then opened up my task manager.

    The Tweaker's process was still running in the background. I killed it.

    I then, without closing the game, logged in again. No 630, no abnormal loading behavior or hangups, EVERYTHING WORKED FINE!!

    I'm going to install the story patch again. If my hypothesis is correct, then killing the Tweaker's process before I actually log in will prevent the 630 issue from occurring at all.

    Holy crap I may have just solved my own problem.

    It came from the UPDATE: Well, I seem to have a solution of sorts. Or at least a workaround.

    For whatever reason, when the Large Files or Story patch are installed, or any patch that uses the TRANS-AM tool, the PSO2 Tweaker does NOT close while the game is running.

    PSO2 apparently doesn't like something about that fact, because I will then proceed to 630 like crazy any time I load into the gate area after log in.

    However, if I kill the Tweaker's process via Task Manager while the game's on the title screen, then I have no problems. The game runs normally and I have no 630s.

    It seems I was right that it wasn't my connection. HentaiLolicon was right in that it wasn't the patches themselves. Apparently, it's the tweaker itself that's the problem here.

    Anyway, I have a workaround, so I'm just going to leave my data-gathering process here in the hopes that it helps AIDA identify and resolve this issue in the tweaker's next release.

    UPDATE The Sequel - Electric Boogaloo: After some testing, it seems my workaround isn't as reliable as it seemed. It's about 50/50 whether it works or not.

    However, I have noticed some interesting behavior. If I let the game 630, and then return to the title screen without closing the game, the next attempt to load into the gate area will generally go off without a hitch.

    Not sure yet whether or not closing the tweaker's process in the background has anything to do with that - so far, I've closed it out every time. I may just let the process sit next time, just to see if it makes any difference. If it doesn't, then I know my alleged workaround is a total flop and that the times it 'worked' were just flukes.

    Still, I'm not mad about that - if indeed the workaround is nothing of the sort, and I just need to let the game 630 and then try again without closing, then that means I can use the item patch, which requires the tweaker in the background.

    You thought you were rid of the UPDATE: I think... I may have fixed it.

    And it had nothing to do with anything discussed so far. I just, on a whim really, reset both the Tweaker's settings and PSO2's using the options in the Tweaker, then re-installed all the patches.

    Sure enough, now I can get into the lobby with absolutely no trouble, even with all the patches active.

    I have no idea what happened.
    Last edited by Nerva; Sep 4, 2015 at 07:07 PM. Reason: Better traceroute example, Updated info as of 9/2

Similar Threads

  1. Replies: 1
    Last Post: Jun 14, 2013, 11:29 PM
  2. I get Error 630 all the time...why?
    By KoNeko1192 in forum PSO2 General
    Replies: 10
    Last Post: Aug 21, 2012, 02:42 AM
  3. Error 630 all the time
    By gweitz in forum PSO2 General
    Replies: 0
    Last Post: Aug 20, 2012, 09:13 PM
  4. Error 630 after loading character.
    By Illuminate in forum PSO2 General
    Replies: 19
    Last Post: Apr 26, 2012, 01:14 PM
  5. Error 630
    By Kimil Adrayne in forum PSO2 General
    Replies: 2
    Last Post: Apr 20, 2012, 12:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts