Results 1 to 1 of 1
  1. #1
    PSO Assassin MasterGunz2345's Avatar
    Join Date
    Oct 2009
    A Little Town Called None Of Your Damn Business

    Default *SOLVED* R Trigger Problems with Xbox One Afterglow Controller HELP!!!

    I had purchased a Xbox One Afterglow Controller since my SteelSeries wireless bluetooth controller kept irking me with the unresponsive, LT and RT problem. When testing it out with PSO2, I was reminded that PSO2 has had a known problem with the RT trigger being unresponsive if you happen to be using a Xbox One Controller since I remember encountering this problem in the past, but not sure why I'm encountering this again if I could of sworn before that I fixed it. To start off with, I have a Windows 10 PC, and I followed guides such as I already have the Xbox One Controller drivers installed, but no luck. I then tried updating the controller via Xbox Accessories, but I was unable to update the firmware since it's a 3rd party controller. I then tried going into Device Manger>Xbox Peripherals>Xbox Gaming Device and manually changing that driver to the Microsoft Xbox One Controller (also tried the DFU version) driver and while the controller vibrates after I restarted my PC like it told me too, the RT still does not work. My next and finally step was to go into Printers & Devices, right click the Afterglow Controller and pretty much follow everything it said to do in the guide which I provided previously, although the part where it says "Do the same and change "XINPUT compatible HID device" to "HID-compliant input device," was not possible since for some reason, "HID-compliant input device" was no where to be found when looking for the disk, so I said screw it (though I feel like this is the main reason I can't get the RT problem resolved but being it's no where on the list, I can't do this step.) Sadly, the R2 is still acting up.

    I'm seriously ripping the hair out of my head trying to get this crap resolved but I'm running out of options. I might try JoyToKey but I would really like to have this damn RT bug fixed. Does anyone have another solution I can try that may fix this? Please help lol thank you!!

    EDIT: Problem solved! Turns out doing something in Gamepad config in PSO2 might of corrected the problem!
    Last edited by MasterGunz2345; Feb 13, 2018 at 07:17 AM.
    Ship 2

Similar Threads

  1. Replies: 1
    Last Post: Dec 31, 2017, 01:26 PM
  2. Replies: 0
    Last Post: May 4, 2017, 05:53 AM
  3. PSO2 Xbox One Elite Controller
    By Chik'Tikka in forum Tech Support
    Replies: 0
    Last Post: Dec 24, 2016, 11:01 PM
  4. Xbox 360 wired controller help ( keys are placed backwards)
    By deusalkaiser in forum PSO2 General
    Replies: 7
    Last Post: Mar 16, 2016, 11:11 AM
  5. Noob problem with Race/Type combo... Please help!
    By Neomaxim in forum PSU: Gameplay, Guides & Walkthroughs
    Replies: 19
    Last Post: Oct 24, 2007, 04:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts